linked objects colors are not rich

View previous topic View next topic Go down

linked objects colors are not rich

Post  Scooter2 on Wed Jul 25, 2012 11:03 pm

Good evening,
I have been setting up scenes with linked objects and found that the colors do not render rich like they do when I render the objects in their original file. I notices all like objects are like that and even look somewhat pastel like in the 3d view.
I set up a simple new test file with simple lighting like their orignal file has and that has the same problem. Presently, there is no use of nodes, compositing, ambiant occlusion or environmental lighting. Just simple to narrow it down.
I notice the objects render faster when linked in and wonder if linking has some form of efficiency system that is causing it.
Any ideas, please let me know. version 2.58
Thanks,
Scooter

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Radialronnie on Thu Jul 26, 2012 12:49 pm

Sharing a .blend file would help a great deal with diagnosing the problem as it sounds like a rather unusual occurrance.

Radialronnie

Posts : 366
Join date : 2012-04-05

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Xraygunner on Thu Jul 26, 2012 10:08 pm

+1 on that. Sounds interesting... although I'd have to wonder if it is taken care of in 2.63 already.
avatar
Xraygunner

Posts : 374
Join date : 2012-04-11
Age : 44

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Scooter2 on Thu Jul 26, 2012 10:19 pm

Good eveing,
Thanks for the reply. Attached is a folder containing part of one of the props I was linking in and a link test file showin what happens. I had to reduce the files down because I have 25k dialup. The tire was part of a truck and the body and tires were a group. The common feature among all of my files is they started life as 2.49b and have been saved in and worked on for some time in 2.58. Just as an experiment I made a new object in 2.49b and saved it to 2.58 then linked it. It did not have a problem. I even added it to a group and added an armature, but still no problems.
If I make a new object in 2.58 and link it there is no problem.
I also have a character with hair and its colors are bland and the hair looks like it has been strand rendered at twice the effect and the color is way off. I will make a sample of it to experiment.
Thanks for looking.
Scooter

Just realized I do not know how to upload here yet. Is there a way to upload a file?


Last edited by Scooter2 on Thu Jul 26, 2012 10:23 pm; edited 1 time in total (Reason for editing : how to upload file?)

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Radialronnie on Fri Jul 27, 2012 12:37 pm

Sorry about the slow internet. I hope it's not too much of an inconvenience.
You can upload files to [You must be registered and logged in to see this link.]
or [You must be registered and logged in to see this link.]
The later requires a (free) account, but will never delete your file. Filedropper will purge after ~30 days of inactivity,
so for a quick share, it might be enough.

Radialronnie

Posts : 366
Join date : 2012-04-05

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Scooter2 on Fri Jul 27, 2012 5:30 pm

Thanks a bunch for letting me know how to do that. I have never used one of those upload sites.
The links are: [You must be registered and logged in to see this link.] and [You must be registered and logged in to see this link.]
If they do not work, let me know. If you do not see on your computer what you think I am explaining, I will send images.
I tried to upload a folder with all files, but could not select the folder.
I remembered last night that I have actually created a linked scene for fun a couple of months using these characters and did not have any problems. I have not made any updates to them or Blender since then. I am going to go through that file compared to a new one button by button to see if there is a difference.
Thanks for looking.
Scooter

I just found a difference between a scene file that has a problem and one that does not. At the screen top header where you select screen layout, the good file has what I am accustome to:
1-Animation
2-Model
3-Material
4-Sequence
5-Scripting
The file with problems has:
Aniamation
Compositing
Default
Game logic
Scripting
UV editing
Video editing
I wonder if that is it. I did not knowingly change this and have not figure out how to put it back. The difference can be seen in the files I uploaded to file dropper.


Yea I found the button!! I arranged my default screen so all scenes would render in same format and apparently I checked "Color management". I do not fully understand what it is for, but did some reading. Unchecking that made all the colors come back including rendered.
Any advice regarding that is appreciated.
Thanks for looking.
Scooter


Last edited by Scooter2 on Fri Jul 27, 2012 6:52 pm; edited 2 times in total (Reason for editing : YEA! Solved!!!)

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Radialronnie on Wed Aug 01, 2012 9:05 pm

Could someone else kindly take a look at this? I'm not getting anything here

Radialronnie

Posts : 366
Join date : 2012-04-05

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Scooter2 on Wed Aug 01, 2012 11:26 pm

Good evening Radialronnie,
I am wondering what you mean by "I'm not getting anything here"? Are the files I uploaded to filedropper.com not coming through? Please let me know if that is the problem.
If you mean that you did not figure out the problem yet, I added a note to the bottom of the last post that I found what happened. The update from 2.49b to 2.58 is where it is. 2.58 has "color management" as default and only works if the files were created using it from the begining.

I never figured out why I have different screen options except perhaps they are legacy from 2.49

Thanks a bunch for looking at it.
Scooter

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Radialronnie on Thu Aug 02, 2012 12:54 pm

Ah, I had not noticed your edit. I'm glad you figured it out!
(I was able to download your files with no issue)

The different screen options are only appearing in files that were originally created in 2.49, right?
If that's the case, I'm guessing the old window preset from 2.49 are now there along with new window presets added with the new version that you're running. There shouldn't be any significant different other than more screen options.

Radialronnie

Posts : 366
Join date : 2012-04-05

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Scooter2 on Thu Aug 02, 2012 11:08 pm

Good evening,
I am pretty sure you are correct that the screen settings are named from files made in 2.49. I have not had any trouble with the new layout though.
Thanks again for looking.
Scooter

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: linked objects colors are not rich

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum