appending actions

View previous topic View next topic Go down

appending actions

Post  Scooter2 on Thu Jun 14, 2012 10:53 pm

Good evening,
I have a batch of characters that are all a copy from the first made. They all have the same names on the bones. I made a walk and run cycle on the first character and have appended it to serveral characters without any trouble. However, two characters have trouble. One needed tweeking and the other is all over the place. I have been trying to figure out how to salvage that as to not make new cycles for that character.
The difference the two characters have from the others is a slight change in scale of the armature. Does anyone know if that would explain the problem. I think maybe the bone key locations are very sensitive and I cant copy to a different scale.
Please let me know.
Thanks,
Scooter

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: appending actions

Post  zyzzy on Fri Jun 15, 2012 3:43 pm

i have an idea, but i'm not around blender right not to see....but i think it is cntrl+a to apply size (also location and rotation)

i'm not sure if that's right, or if that's what the problem is, but it may be worth trying to apply the scale to the armature that has changed.
avatar
zyzzy
Admin

Posts : 118
Join date : 2012-03-28
Location : West Virginia, USA

View user profile http://blenderworld.forumotion.com

Back to top Go down

Re: appending actions

Post  Scooter2 on Fri Jun 15, 2012 7:20 pm

Thanks for the reply,
That sure sounded like a great idea, but I checked the character and must have already applied l,r,s. Because when I did it, nothing changed and I checked transform properties before it, they were at l=000,r=000,s=111.
I sure thought you were on to something and I bet that would certainly make a difference if it had not been done. I did find an old post today that mentioned how unpredictable append is when something is different.
Thanks,
Scooter

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: appending actions

Post  Scooter2 on Sat Jun 16, 2012 1:15 pm

Good morning,
I made a new walk cycle for the first character I found to have a problem. Then I remembered I have a couple of characters that are a copy of that one and the walk cycle appended fine, but will not append from the original that this character is copied from. I found it odd that I have that problem since technically they are all copies of one original. I did find that scale has an effect, but does not appear to be the cause of this problem.
I wonder if some meta data has been corrupted on this character and its copies at some point.
That is what I found anyway and decided fixing them separate was the way to move forward.
Thanks,
Scooter

Scooter2

Posts : 133
Join date : 2012-06-09

View user profile

Back to top Go down

Re: appending actions

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum